Welcome to the Invelos forums. Please read the forum rules before posting.

Read access to our public forums is open to everyone. To post messages, a free registration is required.

If you have an Invelos account, sign in to post.

    Invelos Forums->DVD Profiler: Desktop Technical Support Page: 1  Previous   Next
Video filter doesn't preserve AND setting
Author Message
DVD Profiler Unlimited Registranttrystero
W.A.S.T.E.
Registered: March 16, 2007
Posts: 22
Posted:
PM this userView this user's DVD collectionDirect link to this postReply with quote
DVD Profiler 4.0.0 build 1762 on Windows 10 x64.

I want to save a filter which shows all pan-and-scan-only titles in my collection. So I filter for Video > Video Formats > Pan & Scan > TRUE (checked) and Video > Video Formats > Widescreen > FALSE (empty) and select the AND at the bottom of the Video filter tab; this returns the expected subset of titles.

When I save this filter as a .flt file and re-load it, however, the AND setting gets lost: I get results for Video > Video Formats > Pan and Scan > TRUE (checked) OR Video > Video Formats > Widescreen > FALSE (empty).

The same thing happens for a filter on Video > Video Formats > Full Frame > TRUE (checked) and Video > Video Formats > Widescreen > FALSE (empty); the filter works if I apply it manually, but if I save it and load it, I get the OR results instead of the desired AND results.

In my .flt file, I see a <FilterVideoAnd>true</FilterVideoAnd> element. It looks as though DVD Profiler writes out this tag to indicate that the two video filters should be AND'ed together, but then fails to honour it when re-loading the filter.

Does anyone else see this behavior? Is this just a known issue?
"...self-discipline isn't everything. Look at Pol Pot."
      —Helen Fielding, Bridget Jones: The Edge of Reason
 Last edited: by trystero
DVD Profiler Unlimited RegistrantStar Contributorkaput5
Registered: March 16, 2007
United States Posts: 72
Posted:
PM this userDirect link to this postReply with quote
Same as you,

The Video filter does not save the AND, it reverts to OR, making it impossible to filter out 3D movies and save the filter.

Did you find a way?
DVD Profiler Unlimited Registranttrystero
W.A.S.T.E.
Registered: March 16, 2007
Posts: 22
Posted:
PM this userView this user's DVD collectionDirect link to this postReply with quote
I haven't found any workaround so far.
"...self-discipline isn't everything. Look at Pol Pot."
      —Helen Fielding, Bridget Jones: The Edge of Reason
DVD Profiler Unlimited RegistrantStar Contributorkaput5
Registered: March 16, 2007
United States Posts: 72
Posted:
PM this userDirect link to this postReply with quote
Me neither. I tried changing the flt file, etc, but it ignores whatever is there.

Bug that has to be fixed.
DVD Profiler Unlimited RegistrantStar Contributorkaput5
Registered: March 16, 2007
United States Posts: 72
Posted:
PM this userDirect link to this postReply with quote
I issued a ticket. Let's see.
DVD Profiler Desktop and Mobile RegistrantStar Contributormreeder50
I was out of bullets
Registered: March 29, 2007
Reputation: High Rating
United States Posts: 2,004
Posted:
PM this userEmail this userView this user's DVD collectionDirect link to this postReply with quote
Tags work great for any filter you want.
Marty - Registered July 10, 2004, User since 2002.
DVD Profiler Unlimited RegistrantStar Contributorkaput5
Registered: March 16, 2007
United States Posts: 72
Posted:
PM this userDirect link to this postReply with quote
I agree and I use several. However I am not going to create a 3D tag, when it's already available in the disc data.

I sent a ticket. They asked for more data and they sent it to dev team.

It seems an easy bug to fix. Looking at the .flt file, it seems the Video tab was added later, and where the filter is concerned, it's part of the Format tab. Probably a small defect that does not load the logic for the Video tab.
    Invelos Forums->DVD Profiler: Desktop Technical Support Page: 1  Previous   Next